cPanel EasyApache 3 Kurmak

EasyApache 4 de olmayan Php 5.4 sürümünü özlemişseniz veya opencart 1.5.5.1 kullanıyorsanız bu büyük bir sıkıntı. Çünkü çoğu php komutları 5.5 de çalışmıyor! Başladım internette araştırmaya.

En temizi bir adet vps satın alıp sıfırdan centos ve cpanel kurmak. (Şu linkte biraz karışık da olsa mevcut)

Cpanel – sh latest komutunu çalıştırmadan bir tık önce şu komutu girmenizi isteyeceğim;

touch /etc/install_legacy_ea3_instead_of_ea4

Bunu yazdığınızda “install_legacy_ea3_instead_of_ea4” adında boş bir dosya açacak. Cpanel kurulumunu başlattığınızda bu dosyayı görürse EasyApache 3’ü de kuruyor.

Ancak; Hali hazırda easyapache 4 derlenmiş bir sisteme kurmak isterseniz şunları yapmanız gerekiyor;

mkdir -p /usr/local/apache.ea3/{conf,htdocs,bin}

Sonrasında ise şunu yazın;

/scripts/migrate_ea3_to_ea4 --revert --run

Bu komut taşımaları da halledecektir. Bu işlemi 10 kerede sadece 3-4 kere yedirebilmişimdir. O yüzden temiz kurulum en iyisi.

Not:

Cpanel ekibi EasyApache 3 in update aldığı son sürümün 62 olacağını söyledi. Ayrıca 64. sürümde ise tamamen kalkacakmış. O yüzden bunu kullanan sunucularınızı güncelleme yapmamanızı önereceğim.

Yada en temizi sisteminizi çalışan yüksek verisyon ile güncellemenizdir.

Afiyet olsun 😉

Bir Cevap Yazın